ephyviewer should work with python 2.7, 3.4, 3.5, 3.6.

ephyviewer should work either with Qt4 or Qt5 so theses depency are not mandatory for installation.

Mandatory Dependencies:
  • numpy
  • scipy
  • matplotlib>=2.0
  • pyqtgraph>=0.10.0
  • PyQt4 or PyQt5
For video viewer:
  • pyav

To get the last release:

pip install ephyviewer

To get the last commit not already released:

pip install